Expression Web UI language settings

After installing Expression Web (version 1) and the German language pack on my new PC running the German version of Windows Vista (Home Premium x64), my previously English Expression Web suddenly displayed the user interface (UI) in – you guessed it – German. I’m not sure if the language pack or the operating system is to blame.

Unfortunately it was not possible to fix this using the “Microsoft Office Language Settings 2007” program which I assume came with the language pack. All it did was changing the help files back to English, which was most unhelpful.

Here’s how I fixed it (after reading this knowledge base article):

1. I located the following registry subkey: HKEY_CURRENT_USER\Software\Microsoft\Expression\Web Designer\12.0.

2. I created a new string value called FollowSystemUI and set it to Off (this step is required).

3. I set the UILanguage DWORD value to 1033 (decimal!) which stands for en-US (some other decimal values are de-DE => 1031, fr-FR => 1036, ja-JP => 1041, zh-TW => 1028, you can find some more here).

There’s also a HelpLanguage value but as I mentioned my help files were already being diplayed in English again, so I left it alone.

Please note: It’s entirely possible that there’s an easier way to change the UI language (which I don’t know about). This post only describes what worked for me.

Leave a Reply

Your email address will not be published.

This site uses Akismet to reduce spam. Learn how your comment data is processed.